Browse Source

fix(ci): update docker image for Node orb (#61)

* fix(ci): update docker image for Node orb

CircleCi was complaining about:

```
error npm-check-updates@9.0.1: The engine "node" is incompatible with this module. Expected version ">=10.17". Got "10.16.3"
error Found incompatible module.
```

* fix(ci): docker image

* fix(ci): i18n.language is not defined on ci
master
guhur 2 years ago
committed by GitHub
parent
commit
fe16e28180
  1. 2
      .circleci/config.yml
  2. 2
      src/components/banner/Paypal.jsx
  3. 2
      src/components/layouts/LanguageSelector.jsx
  4. 2
      src/i18n.jsx

2
.circleci/config.yml

@ -2,7 +2,7 @@ version: 2.1
jobs:
build:
docker:
- image: circleci/node:10.16.3
- image: cimg/node:lts
steps:
- checkout
- run:

2
src/components/banner/Paypal.jsx

@ -8,7 +8,7 @@ import { FontAwesomeIcon } from "@fortawesome/react-fontawesome";
const Paypal = props => {
const { t } = props;
let localeStringShort = i18n.language.substring(0, 2);
let localeStringShort = i18n.language? i18n.language.substring(0, 2): "en";
let localeStringComplete =
localeStringShort.toLowerCase() + "_" + localeStringShort.toUpperCase();
if (localeStringComplete === "en_EN") {

2
src/components/layouts/LanguageSelector.jsx

@ -12,7 +12,7 @@ const LanguageSelector = () => {
i18n.changeLanguage(locale);
};
let locale = i18n.language.substring(0, 2).toUpperCase();
let locale = i18n.language? i18n.language.substring(0, 2).toUpperCase() : "EN";
if (locale === "EN") locale = "GB";
return (
<ReactFlagsSelect

2
src/i18n.jsx

@ -12,7 +12,7 @@ i18n
debug: true,
saveMissing: true, // send not translated keys to endpoint
defaultValue: "__STRING_NOT_TRANSLATED__",
react: { useSuspense: false },
keySeparator: ">",
nsSeparator: "|",
backend: {

Loading…
Cancel
Save